So verwenden Sie Pidgin Plugins im Empathy Chat unter Linux

Inhaltsverzeichnis:

So verwenden Sie Pidgin Plugins im Empathy Chat unter Linux
So verwenden Sie Pidgin Plugins im Empathy Chat unter Linux

Video: So verwenden Sie Pidgin Plugins im Empathy Chat unter Linux

Video: So verwenden Sie Pidgin Plugins im Empathy Chat unter Linux
Video: KODI auf dem Raspberry Pi 2023, November
Anonim

Empathy IM ist eine großartige App mit vielen tollen Funktionen. In der Plugin-Abteilung fehlt es jedoch stark. Zum Glück ist es einfach, Empathy einzuschalten, indem Pidgin-Plugins geladen werden. In diesem Lernprogramm wird beschrieben, wie einfach es ist, Pidgin-Plugins in Empathy zu aktivieren. Die Verwendung von Plugins mit dieser App ist dank des Telepathy Haze-Plugins möglich.

Pidgin-Plugins in Empathie

Folgen Sie den Anweisungen unten, um zu erfahren, wie Sie es in Ihrer Linux-Distribution installieren.

Ubuntu

Das Telepathy Haze-Plugin befindet sich in den Ubuntu-Softwarequellen und ist seit einiger Zeit dort. Um den Purple (Pidgin IM) Plugin-Handler unter Ubuntu Linux zu installieren, öffnen Sie ein Terminalfenster und geben Sie den folgenden Befehl ein:

sudo apt install telepathy-haze

Debian

Debian hat das Telepathy Haze-Plugin in Software-Quellen, obwohl es möglicherweise älter ist als andere Linux-Distributionen, da Debian Pakete langsamer aktualisiert. Dies sollte keine Auswirkungen auf Pidgin-Plugins haben.

sudo apt-get install telepathy-haze

Arch Linux

Arch Linux ist immer auf dem neuesten Stand, sodass Benutzer immer die absolut neueste Version von Telepathy Haze auf ihrem Linux-PC erhalten können. Installiere es mit Pacman:

Sudo Pacman -S Telepathie-Dunst

Fedora

Fedora ist, wie auch Arch Linux, relativ neu und verfügt über neuere Pakete als die meisten Betriebssysteme. Dies bedeutet, dass Fedora-Fans die absolut neueste Version von Telepathy Haze installieren können.

Sudo DNF installieren Telepathie-Haze

OpenSUSE

Je nachdem, welche Version von OpenSUSE Sie verwenden, kann Ihre Version von Telepathy Haze abweichen. Öffnen Sie zur Installation ein Terminal und geben Sie den folgenden Befehl ein.

Sudo Zypper installieren Telepathie-Dunst

Gebäude von der Quelle

Telepathie wird in praktisch jeder Linux-Distribution verwendet. Daher sollte es kein Problem geben, ein Paket dafür zu finden. Öffnen Sie ein Terminalfenster, suchen Sie nach "Telepathie-Dunst" und installieren Sie es. Folgen Sie andernfalls diesen Anweisungen, um das Plugin aus dem Quellcode zu erstellen.

Laden Sie zuerst die neueste Version des Quellcodes herunter.

curl https://telepathy.freedesktop.org/releases/telepathy-haze/telepathy-haze-0.8.0.tar.gz> telepathy-haze.tar.gz

Verwendung der TeerBefehl, extrahieren Sie die Dateien aus dem Archiv.

tar -xzvf telepathy-haze.tar.gz

CD-Telepathie-Dunst-0.8.0

Verwendung der Katzeund MehrLesen Sie die enthaltenen INSTALL- und README-Dateien durch. Sehen Sie sich diese an und erfahren Sie, welche Abhängigkeiten Sie benötigen. Achten Sie auch auf andere Anweisungen, die in diesen Dokumenten beschrieben werden, z. B. für Ihr Betriebssystem spezifische Compilereinstellungen usw.

cat INSTALL | mehr Katze README | Mehr

Führen Sie als Nächstes die aus konfigurierenSkript und lassen Sie die Umgebung scannen und einrichten, in der Telepathy Haze kompiliert werden soll.

./konfigurieren

Configure durchsucht Ihren Linux-PC nach Abhängigkeiten und einen Fehler, falls er nicht installiert ist. Tun Sie Ihr Bestes, um sie zu installieren. Sie müssen möglicherweise pkgs.org auf Pakete überprüfen.

Wenn alles gut aussieht, bauen und installieren Sie Telepathy Haze:

sudo make install machen

Empathy IM installieren

Nach der Installation von Telepathy Haze müssen Sie die Empathy-App selbst installieren. Wie Telepathy Haze wird es sehr gut unterstützt, daher sollte es bei der Installation nicht zu viele Probleme geben.

Ubuntu

Mit Ubuntu ist Empathie seit langem enthalten. Wenn Ihre Installation jedoch nicht verfügbar ist, ist die Installation so einfach wie folgt:

Sudo apt Empathie installieren

Debian

Debian wird für seine Instant-Messaging-Anforderungen mit Pidgin ausgeliefert. Empathy kann jedoch problemlos über installiert werden apt-get.

sudo apt-get install empathy

Arch Linux

Wie Telepathy Haze können Arch-Benutzer die neueste Version von Empathy direkt aus den Software-Repositorys beziehen. Installieren Sie es über Pacman:

Sudo Pacman -S Empathie

Fedora

In Fedora ist möglicherweise bereits Empathy installiert, da viele Gnome-Programme verwendet werden. Wenn Sie jedoch einen alternativen Desktop auf Fedora verwenden oder Empathy nicht finden können, installieren Sie ihn mit DNF:

Sudo DNF installieren Empathie

OpenSUSE

Müssen Sie Empathy IM auf OpenSUSE erhalten? Ergreifen Sie es mit dem Paketmanager von Zypper:

Sudo Zypper installieren Empathie

Andere Linuxes

Empathie ist ein großes Programm. Daher dauert es eine Weile, bis sie aus der Quelle erstellt wird. Glücklicherweise verfügt das Gnome-Projekt über eine ausführliche Anleitung, die genau zeigt, wie sie ihre Instant Messenger-Software erstellen. Gehen Sie zu dieser Seite und folgen Sie ihr. Wenn Sie den Empathy-Client installiert haben, kehren Sie zum Handbuch zurück, um zu erfahren, wie Sie Pidgin-Plugins in Empathy installieren.

Pidgin Plugins in Empathy installieren

Das Beste an der Verwendung von Pidgin-Plugins in Empathy IM ist die Tatsache, dass Benutzer während der Installation keine besonderen Schritte unternehmen müssen. Folgen Sie stattdessen den normalen Anweisungen zum Installieren eines Pidgin-Plugins. Empathy findet die Datei und lädt sie.

Hinweis: Pidgin-Plugins finden Sie hier.
Hinweis: Pidgin-Plugins finden Sie hier.

In diesem Beispiel erfahren Sie, wie Sie das RocketChat Pidgin-Plugin installieren. Installieren Sie zuerst die richtigen Abhängigkeiten, die zum Erstellen des Plugins erforderlich sind.

Hinweis: In diesem Beispiel zeigen wir die Abhängigkeiten für Ubuntu, Debian und Fedora. Informationen zu anderen Distributionen finden Sie im offiziellen Leitfaden.

Ubuntu / Debian

sudo apt installieren libpurple-dev libjson-glib-dev libglib2.0-dev mercurial make libmarkdown2-dev

Fedora

sudo dnf install libpurple-devel.x86_64 libmarkdown-devel.x86_64 json-glib-devel.x86_64 glib2.x86_64

Verwendung der hgLaden Sie den RocketChat-Plugin-Quellcode herunter:

Hg-Klon https://bitbucket.org/EionRobb/purple-rocketchat/

CDin die geklont Lila-RocketchatOrdner auf Ihrem PC und führen Sie die machenund installiereBefehle zum Installieren des Plugins.

cd purple-rocketchat make sudo make install

Wenn das Plugin erfolgreich installiert wird und Telepathy Haze funktioniert, sollten Sie RocketChat in "Accounts" in Empathy sehen können.
Wenn das Plugin erfolgreich installiert wird und Telepathy Haze funktioniert, sollten Sie RocketChat in "Accounts" in Empathy sehen können.

Empfohlen: